Jump to content

Custom Search





Welcome to the Chevrolet Cruze Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Chevrolet Cruze forum. You must register to create topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Benefits of membership:
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .more!
Click here to signup now.
 
Guest Message by DevFuse

Photo
- - - - -

thermostat heater control circuit high


  • Please log in to reply
2 replies to this topic

#1 OFFLINE   daveo1021

daveo1021

    New Cruze Member

  • Cruze Members
  • Pip
  • 4 posts
  • Region:U.S. Mississippi Valley
  • Location:springfield illinois
  • My Cruze's Year:2012
  • My Cruze: mycruze
  • Current Vehicle:2012 chevy cruze
  • Interests:thermostats.. going on my 3rd one in less than 1.5 years?

Posted 12 October 2017 - 09:56 PM

already have replaced 2 thermostats.. now I get this code.. thermostat heater circuit high. is this going to be another thermostat or is there something else.. any ideas would be alright before I go spend another 50 bucks on a thermostat







Lose this advertisement by becoming a member. Click here to create a free account.


#2 OFFLINE   SHARONE

SHARONE

    New Cruze Member

  • Cruze Members
  • Pip
  • 17 posts
  • Region:Decline
  • Location:US
  • My Cruze's Year:None
  • My Cruze: mycruze
  • Current Vehicle:Ford
  • Interests:Cars

Posted 16 October 2017 - 09:01 AM

Seems like if it is the third something else is wrong. Good luck if you figure out post info



#3 OFFLINE   daveo1021

daveo1021

    New Cruze Member

  • Cruze Members
  • Pip
  • 4 posts
  • Region:U.S. Mississippi Valley
  • Location:springfield illinois
  • My Cruze's Year:2012
  • My Cruze: mycruze
  • Current Vehicle:2012 chevy cruze
  • Interests:thermostats.. going on my 3rd one in less than 1.5 years?

Posted 05 November 2017 - 07:55 PM

Seems like if it is the third something else is wrong. Good luck if you figure out post info


well I replaced the thermostat again and it's been a couple weeks or so now and everything seems to be good.. we will see the 1st replacement took almost a year then crapped out and the 2nd took a few month.

Edited by daveo1021, 05 November 2017 - 07:57 PM.









0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Privacy Policy Terms of Service ·