Jump to content

Custom Search





Welcome to the Chevrolet Cruze Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Chevrolet Cruze forum. You must register to create topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Benefits of membership:
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .more!
Click here to signup now.
 
Guest Message by DevFuse

Photo
- - - - -

2017 Chevy Cruze Hatchback

Function Power Supply-Start/S

  • Please log in to reply
No replies to this topic

#1 OFFLINE   vpelle

vpelle

    New Cruze Member

  • Cruze Members
  • Pip
  • 1 posts
  • Region:U.S. Great Lakes
  • Location:Michigan
  • My Cruze's Year:2017
  • My Cruze: mycruze
  • Current Vehicle:Pontiac Vibe
  • Interests:Car restoretion

Posted 19 February 2018 - 12:35 PM

Hello, first time posting so before i  ask for help would like to apologies if i am not posting correctly. Hope someone can help with this problem, i'll try and explain the problem in as much details as i can. 2017 Chevy Cruse Hatchback LT Gen2 has the battery, the Fuel module and the Converter ASM-M/ Function Power Supply(part 13514044) module are located in the trunk. The trunk got flooded with water, i removed all the water cleaned all the wire plugs, connections and replaced the battery. I connected the battery terminals and turned the car on, everything worked fine including the engine running and driving normal except the Remote Start, the Radio and the Main information screen would not turn on, from what information I was able to find on the web everyone suggested that the system needed to be reset and without going into all the details i tried but no lock so i started looking in the trunk for some bad connection and that is when i discovered that the "Converter ASM-M/ Function Power Supply module" was damaged form the water. At this point i figured no big deal i'll by a new one and solve problem or so i thought, to my surprise after installing a brand new module(i made sure the part number  and everything else matched) turned the car on, the car drives and sounds like it should but now nothing else works, no gauges, no information screens, no radio and no remote start. I went back and plugged the old module and the car went back to original condition. At this point the only thing I could  think of was that the module needed to be programmed so i stopped by a Chevy dealer and asked if this module would need to be programmed, one guy at the parts department said yes but the guy at the service desk said it should be plug and play but when i told him that i did plugged the new Module and nothing worked than he said the the ECU needs to be flashed and would be $150. So here is my question: Does anyone know if this Module truly needs to be programmed or the ECU flashed or at least point me to the wright direction, I would hate to pay the $ 150 to find out that that was not the problem. Any help would be greatly appreciated. Thank You







Lose this advertisement by becoming a member. Click here to create a free account.









0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Privacy Policy Terms of Service ·